#20274 [Fbk->NoF]: failed to create stream: Too many open files in Unknown on line

From: Date: Thu, 21 Nov 2002 23:11:33 +0000
Subject: #20274 [Fbk->NoF]: failed to create stream: Too many open files in Unknown on line
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-25470@lists.php.net to get a copy of this message
ID: 20274 Updated by: sniper@php.net Reported By: fowler@csufresno.edu -Status: Feedback +Status: No Feedback Bug Type: iPlanet related Operating System: Solaris 8 PHP Version: 4CVS-2002-11-06 New Comment: No feedback was provided. The bug is being suspended because we assume that you are no longer experiencing the problem. If this is not the case and you are able to provide the information that was requested earlier, please do so and change the status of the bug back to "Open". Thank you. Previous Comments: ------------------------------------------------------------------------ [2002-11-12 06:05:51] plbar@sdu.nl Switching to PHP 4.2.3 solved the problem for me. Thanks, wez@php.net. ------------------------------------------------------------------------ [2002-11-08 06:26:02] plbar@sdu.nl I am experiencing the same thing (OS: Solaris 8 and Solaris 7; iPlanet 4.1 webserver SP9; PHP4.0.4pl1). After restarting the webserver, each time I can do a certain (almost always the same) number of requests for a script and then things go wrong with file-access: Warning: fopen("/path/to/file","r") - Error 0 in /path/to/script.php on line 104. After that, filehandles appear to be invalid and after that, when I request the script bestel.php, it cannot be opened: Warning: Failed opening '/path/to/script/bestel.php' for inclusion (include_path='.:/usr/local/lib/php') in Unknown on line 0. If more information is needed for help, I will gladly provide it. ------------------------------------------------------------------------ [2002-11-06 08:43:41] kalowsky@php.net Is there a sample script we can try to reproduce this with? ------------------------------------------------------------------------ [2002-11-06 04:28:41] wez@php.net Does the same script exhibit the same behaviour using PHP 4.2.x? ------------------------------------------------------------------------ [2002-11-06 00:16:52] fowler@csufresno.edu We are running php4-200211030600 with Sun One Web Server 6.0sp4 on Solaris 8. It was compiled with gcc 2.95.3 using './configure' \ '--with-nsapi=/path/to/iplanet/web/server' \ It compiled successfully and runs fine for a few hours but accessing pages soon reports the following: ========== Warning: Unknown(/path/to/doc-root/index.php): failed to create stream: Too many open files in Unknown on line 0 Warning: Failed opening '/path/to/doc-root/index.php' for inclusion (include_path='.:/usr/local/lib/php') in Unknown on line 0 ========== A quick fix is to setup a cron job to restart the web server hourly, but this is not desired. Please let me know if I can provide additional details regarding this issue. Thanks, Jay ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=20274&edit=1

« previous php.bugs (#25470) next »