#20274 [Ctl]: failed to create stream: Too many open files in Unknown on line
| From: | thetaphi@php.net | Date: | Tue, 25 Mar 2003 09:15:37 +0000 |
| Subject: | #20274 [Ctl]: failed to create stream: Too many open files in Unknown on line | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-36373@lists.php.net to get a copy of this message | ||
ID: 20274
Updated by: thetaphi@php.net
Reported By: fowler at csufresno dot edu
Status: Critical
Bug Type: iPlanet related
Operating System: Solaris (all)
PHP Version: 4CVS-2002-11-06
Assigned To: wez
New Comment:
The quick fix (have nothing to do with PHP4 itself):
http://www.thetaphi.de/php-ressources/
Status of this bug keeps "Critical" because it have to be solved,
because CGI mode of PHP is a lot slower than NSAPI mode.
Previous Comments:
------------------------------------------------------------------------
[2003-03-23 09:34:00] thetaphi@php.net
I think in your snapshot it was not included. The file main/streams.c
should be 18.03.02 17:39 or later (version 1.125.2.42).
At this time I suggest to use PHP under solaris in CGI mode. I will put
a NSAPI plugin, that supports starting files with the PHP mime type as
CGI (which is in iPlanet servers not possible).
The NSAPI plugin can soon be downloaded from my website.
------------------------------------------------------------------------
[2003-03-21 13:32:33] fowler at csufresno dot edu
Still seeing it also, but with the entire error message, not just the
tail end of it. Built with php4-STABLE-200303181630.
<br />
<b>Warning</b>: Unknown(/path/to/index.php): failed to open stream:
Too
many open files in <b>Unknown</b> on line <b>0</b><br />
<br />
------------------------------------------------------------------------
[2003-03-21 03:10:16] thetaphi@php.net
The error is not completely fixed: Now only the second line appears:
<br />
<b>Warning</b>: (null)(): Failed opening
'/pangaea/webserver/docs/index.php' for inclusion
(include_path='.:/pangaea/PHP4/lib/php') in <b>Unknown</b> on line
<b>0</b><br />
------------------------------------------------------------------------
[2003-03-20 19:09:23] thetaphi@php.net
Testing the new code at the moment... Will inform you if problem occurs
after several hours of running. Hope not :)
We should write to the coding guidelines that nobody should use
fopen()... in the whole PHP code. There are a lot of extensions which
use fopen to create logfiles etc. All of them can fail on systems with
Solaris and other Unixes with the libc of AT&T.
------------------------------------------------------------------------
[2003-03-20 10:39:10] ewa at buffalo dot edu
having similar problem on:
php4.3.1, solaris 8, apache 1.3.17+ssl_1.48
webserver needs a restart ever 2-3 days otherwise
sites don't load properly and we get errors:
Warning: main() [function.main <http://www.php.net/function.main>]:
Failed
opening 'admissions_navigation.inc' for inclusion
(include_path='.:/usr/local/lib/php') in
/info/www/ubwww/admissions/index.php on line 13
Warning: main(admissions_page.inc) [function.main
<http://www.php.net/function.main>]:
failed to create stream: Too many open files in
/info/www/ubwww/admissions/index.php on line 14
Warning: main() [function.main <http://www.php.net/function.main>]:
Failed
opening 'classes/CONFIG/log_config.inc' for inclusion
(include_path='.:/usr/local/lib/php') in
/info/www/ubwww/admissions/index.php on line 15
Warning: main(classes/class_logger.inc) [function.main
<http://www.php.net/function.main>]: failed to
create stream: Too many
open
files in /info/www/ubwww/admissions/index.php on line 16
Warning: main() [function.main <http://www.php.net/function.main>]:
Failed
opening 'classes/class_logger.inc' for inclusion
(include_path='.:/usr/local/lib/php') in
/info/www/ubwww/admissions/index.php on line 16
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/20274
--
Edit this bug report at http://bugs.php.net/?id=20274&edit=1