#20274 [Fbk]: failed to create stream: Too many open files in Unknown on line

From: Date: Sun, 01 Dec 2002 10:43:03 +0000
Subject: #20274 [Fbk]: failed to create stream: Too many open files in Unknown on line
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-26275@lists.php.net to get a copy of this message
 ID:               20274
 Updated by:       wez@php.net
 Reported By:      fowler@csufresno.edu
 Status:           Feedback
 Bug Type:         iPlanet related
 Operating System: Solaris 8
 PHP Version:      4CVS-2002-11-06
 New Comment:

ngalvin@whitepineclub.com:
Can you try increasing your kernel file descriptor limit
(Try doubling it)?
(Don't ask me how; I don't have Solaris).

It's possible that PHP just uses more files concurrently than it used
to, however, it could also be a leak.



Previous Comments:
------------------------------------------------------------------------

[2002-11-30 18:04:12] ngalvin@whitepineclub.com

P.S.  was able to correct the make issue with 4.2.3 with correct nsapi
include path.

------------------------------------------------------------------------

[2002-11-30 17:44:25] ngalvin@whitepineclub.com

Hello all,
I am experiencing nearly the same issue.  This seems to happen randomly
and is temporarily cleared by a webserver reboot.

Here is what the browser sees;

--- Begin browser output---
Warning: Unknown(/www/whitepine/htdocs/webmail/src/login.php): failed
to create stream: Too many open files in Unknown on line 0

Warning: Failed opening '/www/whitepine/htdocs/webmail/src/login.php'
for inclusion (include_path='.:/usr/local/lib/php') in Unknown on line
0
--- End browser output---

I'm on Solaris 9, Ultra 1.

I'm using PHP 4.3.0ORC2 (installed fine);

- Because 4.1.1 is old and crashes the server when php gets executed. 
(nasty errors in the iplanet6 server log)

- And because 4.2.3 won't compile correctly for me. 
I get this error when trying to 'make' after a configure (my configure
options for all 3 versions are below).

---Begin make output---
Making all in nsapi
/bin/sh /dist/web/php/php-4.2.3/libtool --silent --mode=compile gcc 
-I. -I/dist/web/php/php-4.2.3/sapi/nsapi -I/dist/web/php/php-4.2.3/main
-I/dist/web/php/php-4.2.3 -I/includ
e -I/dist/web/php/php-4.2.3/Zend -I/opt/sfw/mysql/include/mysql
-I/dist/web/php/php-4.2.
3/ext/xml/expat  -D_POSIX_PTHREAD_SEMANTICS -D_POSIX_PTHREAD_SEMANTICS
-D_REENTRANT -I/d
ist/web/php/php-4.2.3/TSRM -g -O2 -pthreads -DZTS -prefer-pic  -c
nsapi.c
nsapi.c:50: nsapi.h: No such file or directory
nsapi.c:51: base/pblock.h: No such file or directory
nsapi.c:52: base/session.h: No such file or directory
nsapi.c:53: frame/req.h: No such file or directory
nsapi.c:54: frame/protocol.h: No such file or directory
nsapi.c:55: base/util.h: No such file or directory
nsapi.c:56: frame/log.h: No such file or directory
*** Error code 1
make: Fatal error: Command failed for target `nsapi.lo'
Current working directory /dist/web/php/php-4.2.3/sapi/nsapi
*** Error code 1
make: Fatal error: Command failed for target `all-recursive'
Current working directory /dist/web/php/php-4.2.3/sapi/nsapi
*** Error code 1
make: Fatal error: Command failed for target `all-recursive'
Current working directory /dist/web/php/php-4.2.3/sapi
*** Error code 1
make: Fatal error: Command failed for target `all-recursive'

---End make output---

--with-mysql=/opt/sfw/mysql --with-nsapi=/opt/iplanet/servers
--enable-track-vars --enable-libgcc --with-gettext

I'm also using gcc 2.95.3 if this helps.
I'm also running Iplanet6 sp4

Does anybody have any ideas?
~Nate

------------------------------------------------------------------------

[2002-11-22 03:38:24] wez@php.net

We can't fix without more info/access to this platform.
Can you try increasing your kernel file descriptor limit?
If that does not work, we'll need some kind of strace
output to see what is going on.



------------------------------------------------------------------------

[2002-11-21 17:47:55] fowler@csufresno.edu

plbar@sdu.nl might have the solution... I was forced to fall back on a
previous build and not able to persue the problem further.

------------------------------------------------------------------------

[2002-11-21 17:11:33] sniper@php.net

No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.



------------------------------------------------------------------------

The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
    http://bugs.php.net/20274

-- 
Edit this bug report at http://bugs.php.net/?id=20274&edit=1



Thread (48 messages)

« previous php.bugs (#26275) next »