#21102 [NEW]: stat, lstat fail if filesize larger than 2 GB

From: Date: Fri, 20 Dec 2002 00:52:37 +0000
Subject: #21102 [NEW]: stat, lstat fail if filesize larger than 2 GB
Groups: php.bugs 
Request: Send a blank email to php-bugs+get-28048@lists.php.net to get a copy of this message
From: bonebakker@attbi.com Operating system: solaris PHP version: 4.2.3 PHP Bug Type: *Directory/Filesystem functions Bug description: stat, lstat fail if filesize larger than 2 GB <?php if (is_file("/tmp/very_large_file")) { echo "is file"; } else { echo "is not"; } ?> ~ if the file /tmp/very_large_file is larger than 2 GB, php reports the error: Warning: stat failed for /tmp/very_large_file (errno=79 - Value too large for defined data type) php_4.2.3 is compiled as an apache_1.3.27 module -- Edit bug report at http://bugs.php.net/?id=21102&edit=1 -- Try a CVS snapshot: http://bugs.php.net/fix.php?id=21102&r=trysnapshot Fixed in CVS: http://bugs.php.net/fix.php?id=21102&r=fixedcvs Fixed in release: http://bugs.php.net/fix.php?id=21102&r=alreadyfixed Need backtrace: http://bugs.php.net/fix.php?id=21102&r=needtrace Try newer version: http://bugs.php.net/fix.php?id=21102&r=oldversion Not developer issue: http://bugs.php.net/fix.php?id=21102&r=support Expected behavior: http://bugs.php.net/fix.php?id=21102&r=notwrong Not enough info: http://bugs.php.net/fix.php?id=21102&r=notenoughinfo Submitted twice: http://bugs.php.net/fix.php?id=21102&r=submittedtwice register_globals: http://bugs.php.net/fix.php?id=21102&r=globals PHP 3 support discontinued: http://bugs.php.net/fix.php?id=21102&r=php3 Daylight Savings: http://bugs.php.net/fix.php?id=21102&r=dst IIS Stability: http://bugs.php.net/fix.php?id=21102&r=isapi

« previous php.bugs (#28048) next »