#21102 [NoF->Opn]: stat, lstat fail if filesize larger than 2 GB

From: Date: Sun, 12 Jan 2003 02:49:47 +0000
Subject: #21102 [NoF->Opn]: stat, lstat fail if filesize larger than 2 GB
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-29806@lists.php.net to get a copy of this message
ID: 21102 Updated by: philip@php.net Reported By: bonebakker@attbi.com -Status: No Feedback +Status: Open Bug Type: *Directory/Filesystem functions Operating System: solaris -PHP Version: 4.2.3 +PHP Version: 4.4.0-dev New Comment: Updating -> 4.4.0-dev / open Previous Comments: ------------------------------------------------------------------------ [2003-01-11 20:10:51] bonebakker@attbi.com [unable to edit bug report] latest CVS tarball does not fix the bug, example still fails with latest release. ------------------------------------------------------------------------ [2003-01-09 01:00:02] php-bugs@lists.php.net No feedback was provided for this bug for over 2 weeks, so it is being suspended automatically. If you are able to provide the information that was originally requested, please do so and change the status of the bug back to "Open". ------------------------------------------------------------------------ [2002-12-22 00:55:50] iliaa@php.net Please try using this CVS snapshot: http://snaps.php.net/php4-latest.tar.gz For Windows: http://snaps.php.net/win32/php4-win32-latest.zip ------------------------------------------------------------------------ [2002-12-19 18:52:37] bonebakker@attbi.com <?php if (is_file("/tmp/very_large_file")) { echo "is file"; } else { echo "is not"; } ?> ~ if the file /tmp/very_large_file is larger than 2 GB, php reports the error: Warning: stat failed for /tmp/very_large_file (errno=79 - Value too large for defined data type) php_4.2.3 is compiled as an apache_1.3.27 module ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=21102&edit=1

« previous php.bugs (#29806) next »