#21102 [Com]: stat, lstat fail if filesize larger than 2 GB

From: Date: Mon, 13 Jan 2003 00:22:30 +0000
Subject: #21102 [Com]: stat, lstat fail if filesize larger than 2 GB
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-29842@lists.php.net to get a copy of this message
ID: 21102 Comment by: bonebakker@attbi.com Reported By: bonebakker@attbi.com Status: Feedback Bug Type: *Directory/Filesystem functions Operating System: solaris PHP Version: 4.4.0-dev New Comment: Current OS is Solaris 9u1, 64 bit kernel. Checking types.h and stat.h indicates that Solaris uses an off_t type for the stat structure. off_t is either a long, or a longlong_t, defined as long long. It seems to me that the stat structure in Solaris has the correct type. This is also indicated by the fact that I can use the stat(2) functions to stat the file in a simple C-program without any errors (and get the correct file size), Solaris does not have a shell stat command (AFAIK). Previous Comments: ------------------------------------------------------------------------ [2003-01-11 21:35:05] pollita@php.net What version of Solaris are you running? Many unixes (even current ones) use a signed int (32-bit) for the st_size element of the stat struct used by their c-library's stat() function. Try taking a look in stat.h and/or types.h if you'd like to confirm this on your local system. Does the stat command (from the shell) return sensible output when run against this file? ------------------------------------------------------------------------ [2003-01-11 20:49:47] philip@php.net Updating -> 4.4.0-dev / open ------------------------------------------------------------------------ [2003-01-11 20:10:51] bonebakker@attbi.com [unable to edit bug report] latest CVS tarball does not fix the bug, example still fails with latest release. ------------------------------------------------------------------------ [2003-01-09 01:00:02] php-bugs@lists.php.net No feedback was provided for this bug for over 2 weeks, so it is being suspended automatically. If you are able to provide the information that was originally requested, please do so and change the status of the bug back to "Open". ------------------------------------------------------------------------ [2002-12-22 00:55:50] iliaa@php.net Please try using this CVS snapshot: http://snaps.php.net/php4-latest.tar.gz For Windows: http://snaps.php.net/win32/php4-win32-latest.zip ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/21102 -- Edit this bug report at http://bugs.php.net/?id=21102&edit=1

« previous php.bugs (#29842) next »