#21102 [Opn->Fbk]: stat, lstat fail if filesize larger than 2 GB

From: Date: Sun, 12 Jan 2003 03:35:06 +0000
Subject: #21102 [Opn->Fbk]: stat, lstat fail if filesize larger than 2 GB
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-29808@lists.php.net to get a copy of this message
ID: 21102 Updated by: pollita@php.net Reported By: bonebakker@attbi.com -Status: Open +Status: Feedback Bug Type: *Directory/Filesystem functions Operating System: solaris PHP Version: 4.4.0-dev New Comment: What version of Solaris are you running? Many unixes (even current ones) use a signed int (32-bit) for the st_size element of the stat struct used by their c-library's stat() function. Try taking a look in stat.h and/or types.h if you'd like to confirm this on your local system. Does the stat command (from the shell) return sensible output when run against this file? Previous Comments: ------------------------------------------------------------------------ [2003-01-11 20:49:47] philip@php.net Updating -> 4.4.0-dev / open ------------------------------------------------------------------------ [2003-01-11 20:10:51] bonebakker@attbi.com [unable to edit bug report] latest CVS tarball does not fix the bug, example still fails with latest release. ------------------------------------------------------------------------ [2003-01-09 01:00:02] php-bugs@lists.php.net No feedback was provided for this bug for over 2 weeks, so it is being suspended automatically. If you are able to provide the information that was originally requested, please do so and change the status of the bug back to "Open". ------------------------------------------------------------------------ [2002-12-22 00:55:50] iliaa@php.net Please try using this CVS snapshot: http://snaps.php.net/php4-latest.tar.gz For Windows: http://snaps.php.net/win32/php4-win32-latest.zip ------------------------------------------------------------------------ [2002-12-19 18:52:37] bonebakker@attbi.com <?php if (is_file("/tmp/very_large_file")) { echo "is file"; } else { echo "is not"; } ?> ~ if the file /tmp/very_large_file is larger than 2 GB, php reports the error: Warning: stat failed for /tmp/very_large_file (errno=79 - Value too large for defined data type) php_4.2.3 is compiled as an apache_1.3.27 module ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=21102&edit=1

« previous php.bugs (#29808) next »