#21986 [Asn->Csd]: Apache won't start with libphp4.so compiled with OpenSSl 0.9.7
| From: | iliaa@php.net | Date: | Fri, 31 Jan 2003 22:16:07 +0000 |
| Subject: | #21986 [Asn->Csd]: Apache won't start with libphp4.so compiled with OpenSSl 0.9.7 | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-31811@lists.php.net to get a copy of this message | ||
ID: 21986
Updated by: iliaa@php.net
Reported By: dev5@es11.com
-Status: Assigned
+Status: Closed
Bug Type: OpenSSL related
Operating System: FreeBSD 4.6.2
PHP Version: 4.3.0
Assigned To: iliaa
New Comment:
This bug has been fixed in CVS.
In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.
In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
Thank you for the report, and for helping us make PHP better.
Previous Comments:
------------------------------------------------------------------------
[2003-01-31 13:02:36] dev5@es11.com
Apache 1.3.27 with modssl 2.8.12:
OpenSSL 0.9.7
Returns an error something like:
"Undefined symbol OpenSSL_..._noconf"
php4.3.0 configured with the following line:
'./configure' '--with-mysql=/usr/local/mysql'
'--with-apxs=/usr/local/apache/bin/apxs' '--enable-track-vars'
'--with-pdflib' '--with-gd' '--with-jpeg-dir=/usr/local/lib'
'--enable-gd-native-ttf' '--with-png-dir=/usr/local/lib'
'--with-xpm-dir=/usr/local/lib' '--with-freetype-dir=/usr/local/lib'
'--with-ttf' '--with-tiff-dir' '--with-zlib' '--enable-ftp'
'--enable-cli' '--with-pspell' --with-openssl
This bug is similar to bug #21947
it seems that there might be a problem with openSSL 0.9.7 and php 4.3.0
together
make test returned 2 FAILS (previously none with openssl 0.9.6e)
1. Fail on error handling
2. Fail on Open SSL create keys (or something like that)
Thanks for help and support
Peter
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=21986&edit=1