#21986 [Csd]: Apache won't start with libphp4.so compiled with OpenSSl 0.9.7
| From: | dev5 at es11 dot com | Date: | Tue, 22 Apr 2003 16:42:49 +0000 |
| Subject: | #21986 [Csd]: Apache won't start with libphp4.so compiled with OpenSSl 0.9.7 | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-38071@lists.php.net to get a copy of this message | ||
ID: 21986
User updated by: dev5 at es11 dot com
Reported By: dev5 at es11 dot com
Status: Closed
Bug Type: OpenSSL related
Operating System: FreeBSD 4.6.2
PHP Version: 4.3.1-dev(feb4 18:30)
Assigned To: iliaa
New Comment:
My resolution to this problem was reverting to the 0.9.6 series
(non-engine version). I thi9nk the latest is 0.9.6i when compiling php.
You can install multiple versions of openssl on your machine. I haven't
tried recompiling php with 0.9.7 series. I suspect that problems arise
from combining the engine and non-engine releases together in openssl
0.9.7. If you're going to try and recompile PHP I suggest backing up
libphp.so in youre libexec dir under apache.
good luck
Peter
Previous Comments:
------------------------------------------------------------------------
[2003-04-20 02:29:03] gil at disatnik dot com
Hello,
I have the same problem here,
FreeBSD 4.6,
I have recently recompiled apache & mod_ssl against openssl 0.9.7b they
both work fine, but when I recompiled php (I had it linked against
0.9.7a before, and it run without any problem although the apache was
linked to 0.9.7b...) I get the same error...
I am using the latest ports dir (cvsup'd 10 hours ago...)
Apache 1.3.27
openssl 0.9.7b
php 4.3.1
------------------------------------------------------------------------
[2003-02-04 16:41:13] dev5 at es11 dot com
I reinstalled apache and made sure the OpenSSL is indeed 0.9.7
same effect... it won't start.
I will contact the openssl, mod_ssl and apache developers and try to
resolve this issue
Thanks again
Peter
------------------------------------------------------------------------
[2003-02-04 14:21:21] iliaa@php.net
Could it be that your Apache & PHP are compiled against different
versions of OpenSSL and that is the cause the problem?
------------------------------------------------------------------------
[2003-02-04 13:58:09] dev5 at es11 dot com
Apache still returns an error:
Syntax error on line 205 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp4.so into server:
/usr/local/apache/libexec/libphp4.so: Undefined symbol
"OPENSSL_add_all_algorithms_noconf"
/usr/local/apache/bin/apachectl startssl: httpd could not be started
system:
Apache 1.3.27
OpenSSL 0.9.7
modssl 2.8.12
php 4.3.1-dev (feb 4 18:30)
make test (php) did not FAIL on any OpenSSL functions, though.
I'm confused. Please help.
Thank you
Peter
------------------------------------------------------------------------
[2003-02-04 13:18:35] dev5 at es11 dot com
issue is no longer a problem on FreeBSD 4.6.2
however bug #21600 came up
Thank you for fixing :)
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/21986
--
Edit this bug report at http://bugs.php.net/?id=21986&edit=1