#21986 [Csd]: Apache won't start with libphp4.so compiled with OpenSSl 0.9.7

From: Date: Tue, 04 Feb 2003 19:58:10 +0000
Subject: #21986 [Csd]: Apache won't start with libphp4.so compiled with OpenSSl 0.9.7
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-32101@lists.php.net to get a copy of this message
ID: 21986 User updated by: dev5@es11.com Reported By: dev5@es11.com Status: Closed Bug Type: OpenSSL related Operating System: FreeBSD 4.6.2 PHP Version: 4.3.1-dev(feb4 18:30) Assigned To: iliaa New Comment: Apache still returns an error: Syntax error on line 205 of /usr/local/apache/conf/httpd.conf: Cannot load /usr/local/apache/libexec/libphp4.so into server: /usr/local/apache/libexec/libphp4.so: Undefined symbol "OPENSSL_add_all_algorithms_noconf" /usr/local/apache/bin/apachectl startssl: httpd could not be started system: Apache 1.3.27 OpenSSL 0.9.7 modssl 2.8.12 php 4.3.1-dev (feb 4 18:30) make test (php) did not FAIL on any OpenSSL functions, though. I'm confused. Please help. Thank you Peter Previous Comments: ------------------------------------------------------------------------ [2003-02-04 13:18:35] dev5@es11.com issue is no longer a problem on FreeBSD 4.6.2 however bug #21600 came up Thank you for fixing :) ------------------------------------------------------------------------ [2003-02-04 12:48:11] dev5@es11.com The problem still appears even in CVS tested on freeshly installed FreeBSD 4.7 with OpenSSL successfully patched for FreeBSD make test still Fails in OpenSSL on creating private keys ------------------------------------------------------------------------ [2003-01-31 16:16:06] iliaa@php.net This bug has been fixed in CVS. In case this was a PHP problem, snapshots of the sources are packaged every three hours; this change will be in the next snapshot. You can grab the snapshot at http://snaps.php.net/. In case this was a documentation problem, the fix will show up soon at http://www.php.net/manual/. In case this was a PHP.net website problem, the change will show up on the PHP.net site and on the mirror sites in short time. Thank you for the report, and for helping us make PHP better. ------------------------------------------------------------------------ [2003-01-31 13:02:36] dev5@es11.com Apache 1.3.27 with modssl 2.8.12: OpenSSL 0.9.7 Returns an error something like: "Undefined symbol OpenSSL_..._noconf" php4.3.0 configured with the following line: './configure' '--with-mysql=/usr/local/mysql' '--with-apxs=/usr/local/apache/bin/apxs' '--enable-track-vars' '--with-pdflib' '--with-gd' '--with-jpeg-dir=/usr/local/lib' '--enable-gd-native-ttf' '--with-png-dir=/usr/local/lib' '--with-xpm-dir=/usr/local/lib' '--with-freetype-dir=/usr/local/lib' '--with-ttf' '--with-tiff-dir' '--with-zlib' '--enable-ftp' '--enable-cli' '--with-pspell' --with-openssl This bug is similar to bug #21947 it seems that there might be a problem with openSSL 0.9.7 and php 4.3.0 together make test returned 2 FAILS (previously none with openssl 0.9.6e) 1. Fail on error handling 2. Fail on Open SSL create keys (or something like that) Thanks for help and support Peter ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=21986&edit=1

« previous php.bugs (#32101) next »