#21986 [Csd]: Apache won't start with libphp4.so compiled with OpenSSl 0.9.7

From: Date: Tue, 04 Feb 2003 22:41:13 +0000
Subject: #21986 [Csd]: Apache won't start with libphp4.so compiled with OpenSSl 0.9.7
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-32127@lists.php.net to get a copy of this message
ID: 21986 User updated by: dev5@es11.com Reported By: dev5@es11.com Status: Closed Bug Type: OpenSSL related Operating System: FreeBSD 4.6.2 PHP Version: 4.3.1-dev(feb4 18:30) Assigned To: iliaa New Comment: I reinstalled apache and made sure the OpenSSL is indeed 0.9.7 same effect... it won't start. I will contact the openssl, mod_ssl and apache developers and try to resolve this issue Thanks again Peter Previous Comments: ------------------------------------------------------------------------ [2003-02-04 14:21:21] iliaa@php.net Could it be that your Apache & PHP are compiled against different versions of OpenSSL and that is the cause the problem? ------------------------------------------------------------------------ [2003-02-04 13:58:09] dev5@es11.com Apache still returns an error: Syntax error on line 205 of /usr/local/apache/conf/httpd.conf: Cannot load /usr/local/apache/libexec/libphp4.so into server: /usr/local/apache/libexec/libphp4.so: Undefined symbol "OPENSSL_add_all_algorithms_noconf" /usr/local/apache/bin/apachectl startssl: httpd could not be started system: Apache 1.3.27 OpenSSL 0.9.7 modssl 2.8.12 php 4.3.1-dev (feb 4 18:30) make test (php) did not FAIL on any OpenSSL functions, though. I'm confused. Please help. Thank you Peter ------------------------------------------------------------------------ [2003-02-04 13:18:35] dev5@es11.com issue is no longer a problem on FreeBSD 4.6.2 however bug #21600 came up Thank you for fixing :) ------------------------------------------------------------------------ [2003-02-04 12:48:11] dev5@es11.com The problem still appears even in CVS tested on freeshly installed FreeBSD 4.7 with OpenSSL successfully patched for FreeBSD make test still Fails in OpenSSL on creating private keys ------------------------------------------------------------------------ [2003-01-31 16:16:06] iliaa@php.net This bug has been fixed in CVS. In case this was a PHP problem, snapshots of the sources are packaged every three hours; this change will be in the next snapshot. You can grab the snapshot at http://snaps.php.net/. In case this was a documentation problem, the fix will show up soon at http://www.php.net/manual/. In case this was a PHP.net website problem, the change will show up on the PHP.net site and on the mirror sites in short time. Thank you for the report, and for helping us make PHP better. ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/21986 -- Edit this bug report at http://bugs.php.net/?id=21986&edit=1

« previous php.bugs (#32127) next »