#26161 [Com]: apache2 "can not" load libphp4.so
| From: | mandl dot t at ikarus dot at | Date: | Tue, 20 Jan 2004 18:13:06 +0000 |
| Subject: | #26161 [Com]: apache2 "can not" load libphp4.so | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-53649@lists.php.net to get a copy of this message | ||
ID: 26161
Comment by: mandl dot t at ikarus dot at
Reported By: artistoex at yahoo dot com
Status: Bogus
Bug Type: Apache2 related
Operating System: Debian/unstable
PHP Version: 4.3.3
New Comment:
I ran into the same problem when compiling php-4.3.4 on a RedHat 8.0
system with apache 2.0.48, mod_perl-1.99_12
Here's my apache2 configure commandline
./configure --prefix=/usr/local/apache2 --enable-layout=Apache
--enable-so --enable-module=access --enable-module=log_config
--enable-module=mime --enable-module=auth --disable-auth-anon
--enable-auth_dbm --enable-auth-digest --disable-example
--enable-deflate --enable-log-config --enable-logio --enable-expires
--enable-headers --enable-usertrack --enable-ssl --enable-cgi
--enable-cgid --enable-http --enable-rewrite --enable-http
--enable-static-support --enable-static-htpasswd
--enable-static-htdigest --enable-static-rotatelogs
--enable-static-logresolve --enable-static-htdbm --enable-static-ab
--enable-static-checkgid --with-mpm=prefork
Note: mod_perl says one should compile apache with mpm=prefork
Detailed error message from php-4.3.4 make test:
Syntax error on line 231 of /usr/local/apache2/conf/httpd.conf:
Cannot load /usr/local/apache2/modules/libphp4.so into server:
/usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3: undefined symbol: _Unwind_GetIP
Any help is appreciated.
Thanks
Previous Comments:
------------------------------------------------------------------------
[2003-11-17 18:10:07] sniper@php.net
Then install PHP also from such a package.
------------------------------------------------------------------------
[2003-11-11 19:09:00] artistoex at yahoo dot com
As I haven't compiled apache on my own I don't know that.
Is there any way to determine that? I installed the apache package
which is brought with Debian/unstable.
------------------------------------------------------------------------
[2003-11-10 20:09:58] iliaa@php.net
Did you compile Apache 2 for thread or fork based model?
------------------------------------------------------------------------
[2003-11-07 03:58:43] artistoex at yahoo dot com
Description:
------------
- i compiled php:
./configure --with-apxs2=/usr/bin/apxs2 --with-mysql
- apache2 says he could not load libphp4.so into server:
Syntax error on line 390 of /etc/apache2/apache2.conf:
Cannot load /usr/lib/apache2/modules/libphp4.so into server:
/usr/lib/apache2/modules/libphp4.so: undefined symbol: core_globals_id
- i am using latest versions of both apache2 and php and the bug still
exists (so is it a php or actually an apache2 bug???)
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=26161&edit=1