#36777 [NEW]: Apache stops serving
| From: | jtaylor at qrsdc dot com | Date: | Fri, 17 Mar 2006 20:58:59 +0000 |
| Subject: | #36777 [NEW]: Apache stops serving | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-94478@lists.php.net to get a copy of this message | ||
From: jtaylor at qrsdc dot com
Operating system: Redhat 9
PHP version: 5.1.2
PHP Bug Type: Apache2 related
Bug description: Apache stops serving
Description:
------------
I have been running PHP 5.1.2 without problems compiled with the following
commands:
./configure --with-apxs2=/etc/httpd/bin/apxs --enable-versioning
--with-mssql=/usr/local/freetds --enable-libxml --with-mysql
--with-iconv=/usr/local --with-gd --with-zlib --enable-ftp
I have been trying to install PDFlib 6.0.3 as a DSO(also tried the Lite
version with same result) without luck. When I try, I get this error:
"Unable to load dynamic library '/usr/local/lib/libpdf_php.so' -
/usr/local/lib/libpdf_php.so: undefined symbol: _zval_ptr_dtor".
So, after looking through the bugs, I decided to try to disable
versioning.
Reproduce code:
---------------
./configure --with-apxs2=/etc/httpd/bin/apxs
--with-mssql=/usr/local/freetds --enable-libxml --with-mysql
--with-iconv=/usr/local --with-gd --with-zlib --enable-ftp
Expected result:
----------------
Normal function...
Actual result:
--------------
This resulted in Apache no longer serving PHP pages (404 error).
--
Edit bug report at http://bugs.php.net/?id=36777&edit=1
--
Try a CVS snapshot (PHP 4.4): http://bugs.php.net/fix.php?id=36777&r=trysnapshot44
Try a CVS snapshot (PHP 5.1): http://bugs.php.net/fix.php?id=36777&r=trysnapshot51
Try a CVS snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=36777&r=trysnapshot60
Fixed in CVS: http://bugs.php.net/fix.php?id=36777&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=36777&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=36777&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=36777&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=36777&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=36777&r=support
Expected behavior: http://bugs.php.net/fix.php?id=36777&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=36777&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=36777&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=36777&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=36777&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=36777&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=36777&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=36777&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=36777&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=36777&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=36777&r=mysqlcfg