#36777 [Opn->Fbk]: Apache stops serving
| From: | tony2001@php.net | Date: | Fri, 17 Mar 2006 21:36:56 +0000 |
| Subject: | #36777 [Opn->Fbk]: Apache stops serving | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-94481@lists.php.net to get a copy of this message | ||
ID: 36777
Updated by: tony2001@php.net
Reported By: jtaylor at qrsdc dot com
-Status: Open
+Status: Feedback
Bug Type: Apache2 related
Operating System: Redhat 9
PHP Version: 5.1.2
New Comment:
Now your report doesn't make any sense to me.
If the problem is not related to PDFLib, why are you talking about
PDFLib at all?
And yes, I can hardly believe that PHP can cause Apache to return 404
error.
Please look into your error log for more info (and post it here).
Previous Comments:
------------------------------------------------------------------------
[2006-03-17 22:26:40] jtaylor at qrsdc dot com
The error occurs without any PDFlib interaction. I have the SO
commented out of the php.ini file. I was trying to configure PHP
without versioning. According to the post
http://pecl.php.net/bugs/bug.php?id=5225&edit=1
there is a problem with
versioning and PDFlib, so I thought I would try to configure without
versioning. Like I said, this has nothing to do with PDFlib. I am only
trying to configure PHP without versioning.
------------------------------------------------------------------------
[2006-03-17 22:06:27] tony2001@php.net
Not PHP or Apache problem.
Looks like PDFLib was built with wrong version of PHP or has some
different problems, please report it to PDFLib developers.
------------------------------------------------------------------------
[2006-03-17 21:58:57] jtaylor at qrsdc dot com
Description:
------------
I have been running PHP 5.1.2 without problems compiled with the
following commands:
./configure --with-apxs2=/etc/httpd/bin/apxs --enable-versioning
--with-mssql=/usr/local/freetds --enable-libxml --with-mysql
--with-iconv=/usr/local --with-gd --with-zlib --enable-ftp
I have been trying to install PDFlib 6.0.3 as a DSO(also tried the Lite
version with same result) without luck. When I try, I get this error:
"Unable to load dynamic library '/usr/local/lib/libpdf_php.so' -
/usr/local/lib/libpdf_php.so: undefined symbol: _zval_ptr_dtor".
So, after looking through the bugs, I decided to try to disable
versioning.
Reproduce code:
---------------
./configure --with-apxs2=/etc/httpd/bin/apxs
--with-mssql=/usr/local/freetds --enable-libxml --with-mysql
--with-iconv=/usr/local --with-gd --with-zlib --enable-ftp
Expected result:
----------------
Normal function...
Actual result:
--------------
This resulted in Apache no longer serving PHP pages (404 error).
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=36777&edit=1