#36777 [Bgs->Opn]: Apache stops serving
| From: | jtaylor at qrsdc dot com | Date: | Fri, 17 Mar 2006 21:26:42 +0000 |
| Subject: | #36777 [Bgs->Opn]: Apache stops serving | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-94480@lists.php.net to get a copy of this message | ||
ID: 36777
User updated by: jtaylor at qrsdc dot com
Reported By: jtaylor at qrsdc dot com
-Status: Bogus
+Status: Open
Bug Type: Apache2 related
Operating System: Redhat 9
PHP Version: 5.1.2
New Comment:
The error occurs without any PDFlib interaction. I have the SO
commented out of the php.ini file. I was trying to configure PHP
without versioning. According to the post
http://pecl.php.net/bugs/bug.php?id=5225&edit=1
there is a problem with
versioning and PDFlib, so I thought I would try to configure without
versioning. Like I said, this has nothing to do with PDFlib. I am only
trying to configure PHP without versioning.
Previous Comments:
------------------------------------------------------------------------
[2006-03-17 22:06:27] tony2001@php.net
Not PHP or Apache problem.
Looks like PDFLib was built with wrong version of PHP or has some
different problems, please report it to PDFLib developers.
------------------------------------------------------------------------
[2006-03-17 21:58:57] jtaylor at qrsdc dot com
Description:
------------
I have been running PHP 5.1.2 without problems compiled with the
following commands:
./configure --with-apxs2=/etc/httpd/bin/apxs --enable-versioning
--with-mssql=/usr/local/freetds --enable-libxml --with-mysql
--with-iconv=/usr/local --with-gd --with-zlib --enable-ftp
I have been trying to install PDFlib 6.0.3 as a DSO(also tried the Lite
version with same result) without luck. When I try, I get this error:
"Unable to load dynamic library '/usr/local/lib/libpdf_php.so' -
/usr/local/lib/libpdf_php.so: undefined symbol: _zval_ptr_dtor".
So, after looking through the bugs, I decided to try to disable
versioning.
Reproduce code:
---------------
./configure --with-apxs2=/etc/httpd/bin/apxs
--with-mssql=/usr/local/freetds --enable-libxml --with-mysql
--with-iconv=/usr/local --with-gd --with-zlib --enable-ftp
Expected result:
----------------
Normal function...
Actual result:
--------------
This resulted in Apache no longer serving PHP pages (404 error).
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=36777&edit=1