#36777 [Opn->Bgs]: Apache stops serving

From: Date: Fri, 17 Mar 2006 21:06:28 +0000
Subject: #36777 [Opn->Bgs]: Apache stops serving
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-94479@lists.php.net to get a copy of this message
ID: 36777 Updated by: tony2001@php.net Reported By: jtaylor at qrsdc dot com -Status: Open +Status: Bogus Bug Type: Apache2 related Operating System: Redhat 9 PHP Version: 5.1.2 New Comment: Not PHP or Apache problem. Looks like PDFLib was built with wrong version of PHP or has some different problems, please report it to PDFLib developers. Previous Comments: ------------------------------------------------------------------------ [2006-03-17 21:58:57] jtaylor at qrsdc dot com Description: ------------ I have been running PHP 5.1.2 without problems compiled with the following commands: ./configure --with-apxs2=/etc/httpd/bin/apxs --enable-versioning --with-mssql=/usr/local/freetds --enable-libxml --with-mysql --with-iconv=/usr/local --with-gd --with-zlib --enable-ftp I have been trying to install PDFlib 6.0.3 as a DSO(also tried the Lite version with same result) without luck. When I try, I get this error: "Unable to load dynamic library '/usr/local/lib/libpdf_php.so' - /usr/local/lib/libpdf_php.so: undefined symbol: _zval_ptr_dtor". So, after looking through the bugs, I decided to try to disable versioning. Reproduce code: --------------- ./configure --with-apxs2=/etc/httpd/bin/apxs --with-mssql=/usr/local/freetds --enable-libxml --with-mysql --with-iconv=/usr/local --with-gd --with-zlib --enable-ftp Expected result: ---------------- Normal function... Actual result: -------------- This resulted in Apache no longer serving PHP pages (404 error). ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=36777&edit=1

« previous php.bugs (#94479) next »