Bug #17604 Updated: Apache 2/MySQL/PHP4/Sablotron Will not compile
| From: | sniper@php.net | Date: | Wed, 05 Jun 2002 22:18:52 +0000 |
| Subject: | Bug #17604 Updated: Apache 2/MySQL/PHP4/Sablotron Will not compile | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-9583@lists.php.net to get a copy of this message | ||
ID: 17604
Updated by: sniper@php.net
Reported By: kevin@kevinfries.com
-Status: Open
+Status: Feedback
Bug Type: Compile Failure
Operating System: Solaris 8 IA
PHP Version: 4.2.1
New Comment:
What version of sablotron is that? And how did you configure it?
--Jani
Previous Comments:
------------------------------------------------------------------------
[2002-06-05 16:04:12] kevin@kevinfries.com
OK, now this gets PHP to configure and make, but it still crashes
apache on restart. I am now back to my original error:
Syntax error on line 230 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/modules/libphp4.so into server: ld.so.1:
/usr/local/apache/bin/httpd: fatal: relocation error: file
/usr/local/lib/libsablot.so.0: symbol
_ZTVN10__cxxabiv120__si_class_type_infoE: referenced symbol not found
apache/bin/apachectl start: httpd could not be started
------------------------------------------------------------------------
[2002-06-05 14:55:54] sniper@php.net
--with-expat-dir=/usr/local/lib
should be:
--with-expat-dir=/usr/local/
------------------------------------------------------------------------
[2002-06-05 11:14:08] kevin@kevinfries.com
The last two lines in the configure.log file are:
configure:63241: checking whether to enable XML support
configure:63290: checking external libexpat install dir
Then Nothing but ~
------------------------------------------------------------------------
[2002-06-05 06:25:11] sander@php.net
Can you post the relevant information in your config.log?
------------------------------------------------------------------------
[2002-06-05 03:36:51] kevin@kevinfries.com
Oops, sorry, coppied from my newsnet posting that got no response, and
I forgot to reference the apache startup error that is referenced in
this message:
Syntax error on line 230 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/modules/libphp4.so into server: ld.so.1:
/usr/local/apache/bin/httpd: fatal: relocation error: file : symbol
_ZTVN10__cxxabiv120__si_class_type_infoE: referenced symbol not found
apachectl start: httpd could not be started
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/17604
--
Edit this bug report at http://bugs.php.net/?id=17604&edit=1