MySQL problem on Yellow Dog Linux

From: Date: Thu, 06 Jun 2002 20:36:11 +0000
Subject: MySQL problem on Yellow Dog Linux
Groups: php.db 
Request: Send a blank email to php-db+get-19654@lists.php.net to get a copy of this message
I'm a relative newbie to the Linux/web server world, having worked with Macs most of my life. I recently installed the Server install of Yellow Dog Linux, with no window managers, CLI only. Everything is working pretty much correctly, except PHP interaction with MySQL. When I tried to install Invision Board, I got the following error‹ Fatal error: Call to undefined function: mysql_connect() in /var/www/default/forums/sm_install.php on line 249 I figured this meant MySQL or PHP was configured incorrectly so I installed PhpMyAdmin to see if that would work, and I got the error message cannot load MySQL extension, please check PHP Configuration. What needs to be configured? I was under the impression that MySQL support was built into PHP now and that it needs no extension. I downloaded the RPM of PHP 4.1.2 (the latest PPC RPM available at rpmfind) and it told me it was already installed. I then installed MySQL 3.23.41 to no effect. So what can I do to fix this? --

« previous php.db (#19654) next »