Re: MySQL problem on Yellow Dog Linux
| From: | Jason Wong | Date: | Thu, 06 Jun 2002 20:48:43 +0000 |
| Subject: | Re: MySQL problem on Yellow Dog Linux | ||
| References: | 1 | Groups: | php.db |
| Request: | Send a blank email to php-db+get-19656@lists.php.net to get a copy of this message | ||
On Friday 07 June 2002 04:36, Garrett Nelson wrote:
> I'm a relative newbie to the Linux/web server world, having worked with
> Macs most of my life. I recently installed the Server install of Yellow Dog
> Linux, with no window managers, CLI only. Everything is working pretty much
> correctly, except PHP interaction with MySQL. When I tried to install
> Invision Board, I got the following error
>
> Fatal error: Call to undefined function: mysql_connect() in
> /var/www/default/forums/sm_install.php on line 249
It means there's no support in php for mysql
> I figured this meant MySQL or PHP was configured incorrectly so I installed
> PhpMyAdmin to see if that would work, and I got the error message
>
> cannot load MySQL extension,
> please check PHP Configuration.
ditto
> What needs to be configured? I was under the impression that MySQL support
> was built into PHP now and that it needs no extension.
Yes and no. PHP has 'builtin' support for MySQL but it needs to be enabled at
compile time.
> I downloaded the RPM
> of PHP 4.1.2 (the latest PPC RPM available at rpmfind) and it told me it
> was already installed. I then installed MySQL 3.23.41 to no effect.
>
> So what can I do to fix this?
Try looking for an RPM with both 'php' and 'mysql' in its name. Eg for Redhat
a suitable rpm would be named: php-mysql-4.1.2-7.i386.rpm.
--
Jason Wong -> Gremlins Associates -> www.gremlins.com.hk
Open Source Software Systems Integrators
* Web Design & Hosting * Internet & Intranet Applications Development *
/*
I generally avoid temptation unless I can't resist it.
-- Mae West
*/