Bug #2259: /etc/httpd/modules/libphp3.so: undefined symbol: fstat
| From: | mev0003 at unt dot edu | Date: | Tue, 07 Sep 1999 22:41:18 +0000 |
| Subject: | Bug #2259: /etc/httpd/modules/libphp3.so: undefined symbol: fstat | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-10680@lists.php.net to get a copy of this message | ||
From: mev0003@unt.edu
Operating system: Linux 2.2.12, RedHat 6.0
PHP version: 3.0.12
PHP Bug Type: Dynamic loading related
Bug description: /etc/httpd/modules/libphp3.so: undefined symbol: fstat
Apache server version is 1.3.6
Configured php 3.0.12 with the following options:
LDFLAGS="-lc" CFLAGS="-fPIC" ./configure --prefix=/usr --with-mysql --with-apxs
\
--with-config-file-path=/etc/httpd --enable-safe-mode \
--with-exec-dir=/usr/bin --with-system-regex --disable-debug \
--with-zlib --enable-debugger --enable-magic-quotes \
--with-pgsql=/usr
Starting httpd gives the following error:
[root@ds9 /root]# /etc/rc.d/init.d/httpd start
Starting httpd:
Syntax error on line 26 of /etc/httpd/conf/httpd.conf:
Cannot load /etc/httpd/modules/libphp3.so into server: /etc/httpd/modules/libphp3.so:
undefined symbol: fstat
[FAILED]
In httpd.conf I have, per INSTALL.REDHAT and INSTALL.DSO:
LoadModule php3_module modules/libphp3.so
AddModule mod_php3.c
In a solution for this problem in php4 on RH 6.0, the writer noted to change lines 75 and 76 in
/usr/sbin/apxs
from:
my $CFG_LD_SHLIB = 'ld'; # substituted via Makefile.tmpl
my $CFG_LDFLAGS_SHLIB = '-Bshareable'; # substituted via Makefile.tmpl
to
my $CFG_LD_SHLIB = 'gcc'; # substituted via Makefile.tmpl
my $CFG_LDFLAGS_SHLIB = '-shared'; # substituted via Makefile.tmpl
This does not work, as -shared is not a legal option for gcc, and with this change, the compile
fails.