RE: Bug id #3386 - Informix related

From: Date: Tue, 03 Oct 2000 08:25:32 +0000
Subject: RE: Bug id #3386 - Informix related
References: 1  Groups: php.dev 
Request: Send a blank email to php-dev+get-34135@lists.php.net to get a copy of this message
-----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1 Hi *, Danny, Jonathan, I received this PHP/Informix problem, basically: cannot build libtool library `libinformix.la' from non-libtool objects: /mpathix/informix/lib/esql/libifsql.a Can you maybe help Tyler? I never seen this one. BTW Tyler, did you enter this in bug database? You probably should. BTW 2, I don't think this have anything to do with bug 3386. Yours, Andrej Falout, http://www.falout.com ICQ 7628616 #----------------------------------------------------------------- globals "I_speak_for_myself.4gl" "Yes we do. If you order online you need to use "NY, 10001" for state and zipcode. Then you can include your original state and zipcode into the message box." - neqx.com on "Do you ship out of US" "We are trying to get a hold of your bank for name and address verification. However the phone numbers we got from MasterCard did not work. Do you have the phone number for your bank?" - neqx.com on "What is e-business" > -----Original Message----- > From: Tyler Bannister [mailto:tyler@nas.net] > Sent: Wednesday, 27 September 2000 07:22 > To: afalout@php.net > Subject: Bug id #3386 > > > Hi, I saw that you were in charge of bug #3386, so I figured I should send > this to you: > > I received the following error when trying to install PHP 4.0.2 into apache > 1.3.11 as a DSO: > > Syntax error on line 242 of > /mpathix/webserver/apache/1.3.11DSO/conf/httpd.conf: Cannot load > /mpathix/webserver/apache/1.3.11DSO/libexec/libphp4.so into server: ld.so.1: > /mpathix/webserver/apache/1.3.11DSO/bin/httpd: fatal: relocation error: > file /mpathix/informix/lib/esql/libifsql.so: symbol ifx_checkAPI: referenced > symbol not found > > I use the following configure: > > ./configure --with-apxs=/mpathix/webserver/apache/httpd/bin/apxs \ > - --with-config-file-path=/mpathix/webserver/apache/httpd/conf \ > --enable-versioning \ > --with-informix \ > --without-mysql \ > --enable-track-vars > > Unless, I am mistaken those are the symptoms of bug #3386, but when I tried > your suggested work around, I got the following error: > > libtool: link: cannot build libtool library `libinformix.la' from > non-libtool objects: /mpathix/informix/lib/esql/libifsql.a > /mpathix/informix/lib/libifasf.a /mpathix/informix/lib/esql/libifgen.a > /mpathix/informix/lib/esql/libifos.a /mpathix/informix/lib/esql/libifgls.a > /mpathix/informix/lib/esql/libifglx.a > make[3]: *** [libinformix.la] Error 1 > make[3]: Leaving directory > `/mpathix/home/tbannist/sol26/php-4.0.2/ext/informix' > make[2]: *** [all-recursive] Error 1 > make[2]: Leaving directory > `/mpathix/home/tbannist/sol26/php-4.0.2/ext/informix' > make[1]: *** [all-recursive] Error 1 > make[1]: Leaving directory `/mpathix/home/tbannist/sol26/php-4.0.2/ext' > make: *** [all-recursive] Error 1 > > Any help you can provide would be appreciated... Hi Andrej, any idea what the problem might be? I've found a couple other bugs that seem similar: Bug id #2452 Bug id #3765 Bug id #6163 I don't know if that will be any help... I did notice that if I have a working version of PHP3 installed into apache (DSO) then I can run apache without getting the checkapi.o missing error (Even though it will occur if I stop loading PHP3). In case you didn't get my last message: Informix IDS: 7.31.UC6 Informix SDK: v2.40 uc1.1 Solaris 2.6 on a Sun Sparc Ultra-5 PHP 4.0.2 Apache 1.3.11 gcc 2.95.2 uname -a gives: SunOS maximus 5.6 Generic_105181-05 sun4u sparc SUNW,Ultra-5_10 - -- Tyler Bannister tbannister@mpathix.com -----BEGIN PGP SIGNATURE----- Version: PGPfreeware 6.0.2i iQA/AwUBOdjvAhZH34ibpTRkEQIzxACg79MBAlInJn1651ZVjPG5nR9OtmEAoOWh aaFYrTUPcdogtJ8WF8F7SOGE =r6UP -----END PGP SIGNATURE-----

« previous php.dev (#34135) next »