array_change_key_case()? key_exists()?

From: Date: Sun, 11 Nov 2001 17:42:50 +0000
Subject: array_change_key_case()? key_exists()?
References: 1  Groups: php.dev php.doc 
Request: Send a blank email to php-dev+get-70142@lists.php.net to get a copy of this message
> goba Sun Nov 11 06:02:32 2001 EDT > > Modified files: > /phpdoc/en/functions array.xml > Log: > Documenting two functions: > > array_change_key_case > key_exists These two functions are really unnecessary IMO, and I'm really wondering why they are here. key_exists: it should be named array_key_exists first, and second, isset($a[key]) simply works fine. A -1 on that one. (I know, and I also read in the archives, about the value-being-NULL issue, but still I don't think key_exists should exist. And array_change_key_case... why?? If going this way, I can think of another million function that might remotely be useful... -1 on that one too. I'm commenting them out of the documentation for now, to prevent users from learning from these functions until this has been discussed. key_exists is in 4.0.6, but array_change_key_case isn't in a released version. --Jeroen

« previous php.dev (#70142) next »