Re: array_change_key_case()? key_exists()?
| From: | Andrei Zmievski | Date: | Sun, 11 Nov 2001 17:58:29 +0000 |
| Subject: | Re: array_change_key_case()? key_exists()? | ||
| References: | 1 | Groups: | php.dev php.doc |
| Request: | Send a blank email to php-dev+get-70144@lists.php.net to get a copy of this message | ||
At 06:42 PM 11/11/01 +0100, Jeroen van Wolffelaar wrote:
These two functions are really unnecessary IMO, and I'm really wondering why they are here. key_exists: it should be named array_key_exists first, and second, isset($a[key]) simply works fine. A -1 on that one. (I know, and I also read in the archives, about the value-being-NULL issue, but still I don't think key_exists should exist.Rename key_exists() to array_key_exists() if you want, but I am +1 for keeping that function. Precisely because of value-being-NULL issue. -Andrei