Bug #14587 Updated: Can't start Apache

From: Date: Tue, 18 Dec 2001 19:46:07 +0000
Subject: Bug #14587 Updated: Can't start Apache
References: 1  Groups: php.dev 
Request: Send a blank email to php-dev+get-74308@lists.php.net to get a copy of this message
ID: 14587 Updated by: derick Reported By: bs@cpfs.mpg.de Old Status: Open Status: Feedback Bug Type: Apache related Operating System: Tru64 UNIX V4.0F Patchkit 6 PHP Version: 4.1.0 New Comment: Okay... is there something like strace for Tru 64? And what does 'nm /path/to/mod_php4.so' show? Derick Previous Comments: ------------------------------------------------------------------------ [2001-12-18 14:43:15] bs@cpfs.mpg.de Derick, I've just done what you suggested. No more output, though. By the way: Searching the bug database I've found that my problem is exactly the same as bug id #7551, which was reported for version 4.0.3pl1 running on a Tru64 machine. Regards, Burkhard. ------------------------------------------------------------------------ [2001-12-18 13:53:03] derick@php.net This is with apachectl start I presume? Can you try it by just starting httpd by hand? It should give a better message then. regards, Derick ------------------------------------------------------------------------ [2001-12-18 13:50:34] bs@cpfs.mpg.de Unfortunately, the error isn't more specific. What I cited was all the output from Apache. Burkhard. ------------------------------------------------------------------------ [2001-12-18 13:45:05] derick@php.net Does it say on which symbol it fails (ie. uncompress). If it's uncompress, add --with-zlib to configure. regards, Derick ------------------------------------------------------------------------ [2001-12-18 13:36:31] bs@cpfs.mpg.de Upon trying to start Apache, I get the error message Syntax error on line 205 of /usr/local/apache/pro/conf/httpd.conf: Cannot load /usr/local/apache/pro/libexec/libphp4.so into server: dlopen: cannot load /usr/local/apache/pro/libexec/libphp4.so and Apache refuses to start. This does not happen with libphp4.so Version 4.0.6. For PHP, I used ./configure --prefix=/usr/local/php/pro --with-mysql --with-apxs=/usr/local/apache/pro/bin/apxs Apache version: 1.3.22 ------------------------------------------------------------------------ Edit this bug report at http://bugs.php.net/?id=14587&edit=1

« previous php.dev (#74308) next »