Bug #14587 Updated: Can't start Apache
| From: | bs at cpfs dot mpg dot de | Date: | Wed, 19 Dec 2001 13:20:15 +0000 |
| Subject: | Bug #14587 Updated: Can't start Apache | ||
| References: | 1 | Groups: | php.dev |
| Request: | Send a blank email to php-dev+get-74387@lists.php.net to get a copy of this message | ||
ID: 14587
User updated by: bs@cpfs.mpg.de
Reported By: bs@cpfs.mpg.de
Old Status: Feedback
Status: Open
Bug Type: Apache related
Operating System: Tru64 UNIX V4.0F Patchkit 6
PHP Version: 4.1.0
New Comment:
Derick,
strace is available for Tru64. And "nm /path/to/libphp4.so" gives a huge number of lines
output. I presume I shouldn't fill in these lines here?
I've tried something different: I recompiled Apache, this time explicitly telling it where to
find perl (/usr/local/bin/perl found by the Apache configure script is actually a symbolic link to
/path/to/perl, and I suspected that somehow this was the origin of my problem). I recompiled PHP and
voila: Loading libphp4.so was OK, with this message in the error_log:
[Wed Dec 19 13:55:52 2001] [notice] Apache/1.3.22 (Unix) PHP/4.1.0 configured -- resuming normal
operations
Thank you for your lightning fast responses to my issue!
Regards, Burkhard.
Previous Comments:
------------------------------------------------------------------------
[2001-12-18 14:46:07] derick@php.net
Okay... is there something like strace for Tru 64?
And what does 'nm /path/to/mod_php4.so' show?
Derick
------------------------------------------------------------------------
[2001-12-18 14:43:15] bs@cpfs.mpg.de
Derick,
I've just done what you suggested. No more output, though.
By the way: Searching the bug database I've found that my problem is exactly the same as bug id
#7551, which was reported for version 4.0.3pl1 running on a Tru64 machine.
Regards, Burkhard.
------------------------------------------------------------------------
[2001-12-18 13:53:03] derick@php.net
This is with apachectl start I presume? Can you try it by just starting httpd by hand? It should
give a better message then.
regards,
Derick
------------------------------------------------------------------------
[2001-12-18 13:50:34] bs@cpfs.mpg.de
Unfortunately, the error isn't more specific. What I cited was all the output from Apache.
Burkhard.
------------------------------------------------------------------------
[2001-12-18 13:45:05] derick@php.net
Does it say on which symbol it fails (ie. uncompress).
If it's uncompress, add --with-zlib to configure.
regards,
Derick
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/?id=14587
Edit this bug report at http://bugs.php.net/?id=14587&edit=1