Re: Re: cvs: php4 /ext/session mod_mm.c

From: Date: Wed, 06 Mar 2002 08:45:45 +0000
Subject: Re: Re: cvs: php4 /ext/session mod_mm.c
References: 1  Groups: php.dev 
Request: Send a blank email to php-dev+get-80782@lists.php.net to get a copy of this message
On Wed, 6 Mar 2002, Yasuo Ohgaki wrote: > Derick Rethans wrote: > >>>It's rather see it fail here, that way it is very obvious to the user that > >>>something is not correct. The way you do not now will make sessions not > >>>work, and there is not a very obvious reason why not. > >>> > >>> > >>Web server will stop with "Failed to start mm session" at start up. > >>(I don't recall exact message) > >> > > > > Let it fail! Better have it fail at start up then ignoring a problem. > > Please revert this. > > > If user uses save_path for their user defiend save handler and > wrong save_path (ie: save_path is not a directory, but db connection > string, etc). User cannot _START_ web server if they include mm > session support. I don't thisk this is what we want. I think it is exactly what we want. When an admin can not start a webserver, he knows that something is wrong, and can fix it immediately. If something is wrong, an admin should know that as soon as possible, and if you 'hide' this error when starting, it's going to give a WTF situation. Derick --------------------------------------------------------------------- PHP: Scripting the Web - www.php.net - derick@php.net All your branches are belong to me! SRM: Site Resource Manager - www.vl-srm.net ---------------------------------------------------------------------

« previous php.dev (#80782) next »