Re: [PATCH] new idate() - sunrise() - sunset() functions
| From: | Andi Gutmans | Date: | Fri, 07 Feb 2003 12:11:19 +0000 |
| Subject: | Re: [PATCH] new idate() - sunrise() - sunset() functions | ||
| References: | 1 2 3 | Groups: | php.dev |
| Request: | Send a blank email to php-dev+get-94087@lists.php.net to get a copy of this message | ||
At 12:47 PM 2/7/2003 +0200, moshe doron wrote:
"Andi Gutmans" <andi@zend.com> wrote in message news:5.1.0.14.2.20030207102137.03bc7798@127.0.0.1... I haven't been following this whole discussion. However, the function names should follow the coding standards and be named something like date_sunrise(), date_sunset() (or whatever other prefix makes sense). here is part of my replay to Leon Atkinson: Also, shouldn't sunrise() and sunset() be cal_sunrise() and cal_sunset()? well, since sunset() & sunrise() have aspects more then cal_* related, i thought the right place is standard. new astronomy extension, or linking against exisint lib, 'll be overhead since i want use it on the calendar extension, that is build by default on VC.Even functions in standard have a prefix. Only ancient ones don't and we didn't fix them for BC reasons. Andi