Bug #70059 [NEW]: FPM does not accept '#' as comment anymore
| From: | mfischer@php.net | Date: | Mon, 13 Jul 2015 06:10:43 +0000 |
| Subject: | Bug #70059 [NEW]: FPM does not accept '#' as comment anymore | ||
| Groups: | php.doc.bugs | ||
| Request: | Send a blank email to doc-bugs+get-12513@lists.php.net to get a copy of this message | ||
From: mfischer
Operating system: Ubuntu 14.04.2 LTS
PHP version: 7.0.0beta1
Package: Documentation problem
Bug Type: Bug
Bug description:FPM does not accept '#' as comment anymore
Description:
------------
I'm pretty sure this has changed, as I was running a 5.6 FPM
installation with line comments starting with '#' and they didn't work
anymore:
[11-Jul-2015 19:30:05] ERROR: [/etc/php5/fpm/pool.d/app.conf:9] value is
NULL for a ZEND_INI_PARSER_ENTRY
[11-Jul-2015 19:30:05] ERROR: Unable to include
/etc/php5/fpm/pool.d/app.conf from /etc/php5/fpm/php-fpm.conf at line 9
[11-Jul-2015 19:30:05] ERROR: failed to load configuration file
'/etc/php5/fpm/php-fpm.conf'
[11-Jul-2015 19:30:05] ERROR: FPM initialization failed
Once I replaced the '#' with a ';' it worked
Maybe it's worth an entry in the Upgrading guide or similar.
--
Edit bug report at https://bugs.php.net/bug.php?id=70059&edit=1
--
Try a snapshot (PHP 5.4): https://bugs.php.net/fix.php?id=70059&r=trysnapshot54
Try a snapshot (PHP 5.5): https://bugs.php.net/fix.php?id=70059&r=trysnapshot55
Try a snapshot (trunk): https://bugs.php.net/fix.php?id=70059&r=trysnapshottrunk
Fixed in SVN: https://bugs.php.net/fix.php?id=70059&r=fixed
Fixed in release: https://bugs.php.net/fix.php?id=70059&r=alreadyfixed
Need backtrace: https://bugs.php.net/fix.php?id=70059&r=needtrace
Need Reproduce Script: https://bugs.php.net/fix.php?id=70059&r=needscript
Try newer version: https://bugs.php.net/fix.php?id=70059&r=oldversion
Not developer issue: https://bugs.php.net/fix.php?id=70059&r=support
Expected behavior: https://bugs.php.net/fix.php?id=70059&r=notwrong
Not enough info: https://bugs.php.net/fix.php?id=70059&r=notenoughinfo
Submitted twice: https://bugs.php.net/fix.php?id=70059&r=submittedtwice
register_globals: https://bugs.php.net/fix.php?id=70059&r=globals
PHP 4 support discontinued: https://bugs.php.net/fix.php?id=70059&r=php4
Daylight Savings: https://bugs.php.net/fix.php?id=70059&r=dst
IIS Stability: https://bugs.php.net/fix.php?id=70059&r=isapi
Install GNU Sed: https://bugs.php.net/fix.php?id=70059&r=gnused
Floating point limitations: https://bugs.php.net/fix.php?id=70059&r=float
No Zend Extensions: https://bugs.php.net/fix.php?id=70059&r=nozend
MySQL Configuration Error: https://bugs.php.net/fix.php?id=70059&r=mysqlcfg