Bug #70059 [Opn->Nab]: FPM does not accept '#' as comment anymore
| From: | laruence@php.net | Date: | Mon, 13 Jul 2015 07:19:36 +0000 |
| Subject: | Bug #70059 [Opn->Nab]: FPM does not accept '#' as comment anymore | ||
| References: | 1 | Groups: | php.doc.bugs |
| Request: | Send a blank email to doc-bugs+get-12515@lists.php.net to get a copy of this message | ||
Edit report at https://bugs.php.net/bug.php?id=70059&edit=1
ID: 70059
Updated by: laruence@php.net
Reported by: mfischer@php.net
Summary: FPM does not accept '#' as comment anymore
-Status: Open
+Status: Not a bug
Type: Bug
Package: Documentation problem
Operating System: Ubuntu 14.04.2 LTS
PHP Version: 7.0.0beta1
Block user comment: N
Private report: N
New Comment:
actually, there is: https://github.com/php/php-src/blob/master/UPGRADING#L425
thanks
Previous Comments:
------------------------------------------------------------------------
[2015-07-13 06:10:40] mfischer@php.net
Description:
------------
I'm pretty sure this has changed, as I was running a 5.6 FPM installation with line comments
starting with '#' and they didn't work anymore:
[11-Jul-2015 19:30:05] ERROR: [/etc/php5/fpm/pool.d/app.conf:9] value is NULL for a
ZEND_INI_PARSER_ENTRY
[11-Jul-2015 19:30:05] ERROR: Unable to include /etc/php5/fpm/pool.d/app.conf from
/etc/php5/fpm/php-fpm.conf at line 9
[11-Jul-2015 19:30:05] ERROR: failed to load configuration file
'/etc/php5/fpm/php-fpm.conf'
[11-Jul-2015 19:30:05] ERROR: FPM initialization failed
Once I replaced the '#' with a ';' it worked
Maybe it's worth an entry in the Upgrading guide or similar.
------------------------------------------------------------------------
--
Edit this bug report at https://bugs.php.net/bug.php?id=70059&edit=1