Re: libphp4.so loading error
| From: | Rasmus Lerdorf | Date: | Sun, 09 Sep 2001 16:40:31 +0000 |
| Subject: | Re: libphp4.so loading error | ||
| References: | 1 | Groups: | php.install |
| Request: | Send a blank email to php-install+get-4256@lists.php.net to get a copy of this message | ||
> After I installed PHP as a dynamic module, I get an error message when I
> try to start Apache which says "syntax error...cannot
> load/usr/local/apache/libexec/libphp4.so into server:
> libmysqlclient.so.10: cannot load shared object file: No such file or
> directory. libmysqlclient.so.10 is located at /mysql/lib/mysql/lib.
>
> I added "/usr/local/mysql" to the /etc/ld.so.config file and ran ldconfig,
> but that didn't make it load. Can anyone help me with this? I really would
> appreciate it.
Once again you are being inconsistent. You say that libmysqlclient.so.10
is in /mysql/lib/mysql/lib but you added /usr/local/mysql to
/etc/ld.so.config
First, "/mysql/lib/mysql/lib" is not the same as "/usr/local/mysql"
and second, the file you are supposed to add it to is "/etc/ld.so.conf"
-Rasmus