Re: libphp4.so loading error

From: Date: Sun, 09 Sep 2001 17:26:58 +0000
Subject: Re: libphp4.so loading error
References: 1 2  Groups: php.install 
Request: Send a blank email to php-install+get-4258@lists.php.net to get a copy of this message
I apologize for my lack of clarity. libmysqlclient.so.10 is located at /usr/local/mysql/lib/mysql/lib. I added "/usr/local/mysql" to "/etc/ld.so.conf" and ran ldconfig. Any assistance you can give me with this would be greatly appreciated. Lawonna In article <Pine.LNX.4.33.0109090938410.1177-100000@rasmus.php.net>, "Rasmus Lerdorf" <rasmus@php.net> wrote: >> After I installed PHP as a dynamic module, I get an error message when >> I try to start Apache which says "syntax error...cannot >> load/usr/local/apache/libexec/libphp4.so into server: >> libmysqlclient.so.10: cannot load shared object file: No such file or >> directory. libmysqlclient.so.10 is located at /mysql/lib/mysql/lib. >> >> I added "/usr/local/mysql" to the /etc/ld.so.config file and ran >> ldconfig, but that didn't make it load. Can anyone help me with this? I >> really would appreciate it. > Once again you are being inconsistent. You say that > libmysqlclient.so.10 is in /mysql/lib/mysql/lib but you added > /usr/local/mysql to /etc/ld.so.config > First, "/mysql/lib/mysql/lib" is not the same as "/usr/local/mysql" and > second, the file you are supposed to add it to is "/etc/ld.so.conf" > -Rasmus >

« previous php.install (#4258) next »