Rename PhpToken::getAll()?

From: Date: Sat, 07 Nov 2020 09:09:32 +0000
Subject: Rename PhpToken::getAll()?
Groups: php.internals 
Request: Send a blank email to internals+get-112189@lists.php.net to get a copy of this message
Hi internals, Cross-posting from https://bugs.php.net/bug.php?id=80328 to a place where someone might see it... The PhpToken::getAll() API introduced in PHP 8.0 is of course inspired by the existing token_get_all() function. But arguably, the name is not that great. The reporter suggests to rename it into PhpToken::tokenize() instead, which seems like a sensible suggestion to me. Any thoughts on doing that rename? It's pretty late in the release cycle, but if we want to rename something, this is our last chance :) Regards, Nikita PS: Because I know someone is going to suggest it: No, we will not introduce a separate PhpLexer class at this point in time.

« previous php.internals (#112189) next »