Re: Rename PhpToken::getAll()?

From: Date: Sat, 07 Nov 2020 20:30:27 +0000
Subject: Re: Rename PhpToken::getAll()?
References: 1  Groups: php.internals 
Request: Send a blank email to internals+get-112198@lists.php.net to get a copy of this message
On Sat, Nov 7, 2020 at 3:09 AM Nikita Popov <nikita.ppv@gmail.com> wrote: > The PhpToken::getAll() API introduced in PHP 8.0 is of course inspired by > the existing token_get_all() function. But arguably, the name is not that > great. > > The reporter suggests to rename it into PhpToken::tokenize() instead, which > seems like a sensible suggestion to me. > > Any thoughts on doing that rename? It's pretty late in the release cycle, > but if we want to rename something, this is our last chance :) > > Do I love a rename 3 weeks from GA? No. Is there any good reason to object? Not really. The change is super minor and the functionality is new and as-yet undocumented. Go for it. The reasoning in favor is sound. -Sara

« previous php.internals (#112198) next »