Re: Rename PhpToken::getAll()?

From: Date: Sat, 07 Nov 2020 14:30:02 +0000
Subject: Re: Rename PhpToken::getAll()?
References: 1  Groups: php.internals 
Request: Send a blank email to internals+get-112193@lists.php.net to get a copy of this message
On Sat, Nov 7, 2020, 10:10 Nikita Popov <nikita.ppv@gmail.com> wrote: > Hi internals, > > Cross-posting from https://bugs.php.net/bug.php?id=80328 to a > place where > someone might see it... > > The PhpToken::getAll() API introduced in PHP 8.0 is of course inspired by > the existing token_get_all() function. But arguably, the name is not that > great. > > The reporter suggests to rename it into PhpToken::tokenize() instead, which > seems like a sensible suggestion to me. > > Any thoughts on doing that rename? It's pretty late in the release cycle, > but if we want to rename something, this is our last chance :) > > Regards, > Nikita > > PS: Because I know someone is going to suggest it: No, we will not > introduce a separate PhpLexer class at this point in time. > Agreed, and as one of PHP 8.0 RM, I see no problem on doing this renaming, just make sure to document it. Naming stuff is hard, but it's never too late to improve it :) >

« previous php.internals (#112193) next »