Re: [VOTE] Random Extension Improvement
| From: | Guilliam Xavier | Date: | Mon, 18 Jul 2022 11:18:56 +0000 |
| Subject: | Re: [VOTE] Random Extension Improvement | ||
| References: | 1 2 3 4 5 6 7 8 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-118272@lists.php.net to get a copy of this message | ||
> For example, what about the
$binaryString argument name?
I would recommend to either keep $string (conservative) or rename it
to $bytes (consistent with the new function name) [I interpret the
RFCs as the former, but the implementation is currently as the
latter].
About your other mail, I too like the idea to split `getInt(int $min =
UNKNOWN, int $max = UNKNOWN) into distinct nextInt()` and
getInt(int $min, int $max) [in a subsequent PR, IIUC].
Regards,
--
Guilliam Xavier