Re: [RFC] [VOTE] Deprecations for PHP 8.4
| From: | Mike Schinkel | Date: | Fri, 02 Aug 2024 06:34:46 +0000 |
| Subject: | Re: [RFC] [VOTE] Deprecations for PHP 8.4 | ||
| References: | 1 2 3 4 5 6 7 8 9 10 11 12 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-124711@lists.php.net to get a copy of this message | ||
> On Jul 31, 2024, at 5:15 PM, Morgan <Weedpacket@varteg.nz> wrote:
> A problem is that MD5 should _not_ be one of the most commonly used algorithms.
Tell that to:
- RFC 2846 - Internet Message Format (IMF) Extensions for Internet Mail
- RFC 3229 - Delta-Encoding in HTTP
- RFC 4151 - The Internet IP Traffic Archive, and
- RFC 4964 - Use of MD5 for IP Version 4 and Version 6 Address Identification
> Also, providing a dedicated function for an algorithm over and above others that don't get
> such special treatment inflates use of that algorithm, making it more commonly used. It becomes
> self-reinforcing.
Well that would be an easy fix: Provide special treatment for the preferred algorithms, i.e. their
own specific function(s).
-Mike