Re: PHP 6.0 Wishlist
| From: | Maxim Matyukhin | Date: | Mon, 15 Aug 2005 08:01:28 +0000 |
| Subject: | Re: PHP 6.0 Wishlist | ||
| References: | 1 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-18094@lists.php.net to get a copy of this message | ||
Just my 2 cents :
9. I don't know current status of apache_hooks (http://cvs.php.net/php-src/sapi/apache_hooks/) but it would be nice to make it stable with good documentation on php.net
10. make standarts for function's names.
For example php has str_replace() and strpos(). I think last function should be named str_pos().
But if namespaces will be added to internal functions (str:replace, str:pos) it will be unnesseccary.
11. +1 namespaces
12. disable @ via settings
13. add keyword 'finally' to exceptions
Rasmus Lerdorf :
Since we are breaking a lot of stuff in 6.0, at least with Unicode_semantics=On I am wondering if it may not be time to break some more stuff and do a bit of spring cleaning. It would mean many apps would need some work to work on PHP 6, but at the same time I think it is work people would welcome since it would mostly involve removing hacks instead of adding them. And yes, I know this is pretty controversial, so take a few deep breaths before replying, please. 1. Remove register_globals completely 2. Remove magic_quotes_* 3. Add input filter extension which will include a mechanism for application developers to very easily turn it off which would swap the raw GPC arrays back in case the site had it turned on by default. 4. Include an opcode cache by default. A lot of work has gone into pecl/apc recently, but I am not hung up on which one goes in. 5. Remove safe_mode and focus on open_basedir 6. Remove some stuff that has been marked deprecated since PHP 3/4 A couple of others that we could consider, but I don't actually think wins us much apart from academic purity (which I have never been all that keen on) are: 7. Make identifiers case-sensitive 8. Remove various function aliases -Rasmus