Re: [SPAM] Re: [PHP-DEV] Syntactic improvement to array

From: Date: Sun, 04 Feb 2007 19:00:26 +0000
Subject: Re: [SPAM] Re: [PHP-DEV] Syntactic improvement to array
References: 1 2 3 4 5 6  Groups: php.internals 
Request: Send a blank email to internals+get-27762@lists.php.net to get a copy of this message
On Sun, 4 Feb 2007, Edin Kadribasic wrote: > I don't find: > > $a = [1 => ['pears', 'apples'], 2 => ['juice', > 'oranges']]; > > any less readable than: > > $a = array(1 => array('pears', 'apples'), 2 => > array('juice', 'oranges')); > > Quite the opposite actually :) That's a personal thing, and I disagree. The array() syntax is clearer. regards, Derick

« previous php.internals (#27762) next »