Re: Syntactic improvement to array
| From: | Stanislav Malyshev | Date: | Sun, 04 Feb 2007 20:18:46 +0000 |
| Subject: | Re: Syntactic improvement to array | ||
| References: | 1 2 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-27767@lists.php.net to get a copy of this message | ||
IA>>I personally find array extremely clear, in recent weeks I had to do A
IA>>LOT of JavaScript work where the array syntax works in a manner you
IA>>suggest for PHP and its a massive pain. It does not make for a very
By pure coincidence, I was doing a bunch of javascript work lately too,
and I find [] syntax OK. From readability POV it's not much difference,
but much less clutter if you have really massive data array - no array()
things which take half of the space.
--
Stanislav Malyshev, Zend Products Engineer
stas@zend.com http://www.zend.com/