Re: [SPAM] Re: [PHP-DEV] Syntactic improvement to array
| From: | Stefan Walk | Date: | Sun, 04 Feb 2007 20:46:16 +0000 |
| Subject: | Re: [SPAM] Re: [PHP-DEV] Syntactic improvement to array | ||
| References: | 1 2 3 4 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-27769@lists.php.net to get a copy of this message | ||
Steph wrote:
> Hi Stas,
>
>> By pure coincidence, I was doing a bunch of javascript work lately
>> too, and I find [] syntax OK. From readability POV it's not much
>> difference, but much less clutter if you have really massive data
>> array - no array() things which take half of the space.
>
> Fine, but in javascript there is only one option. That's the difference.
>
> - Steph
a = Array(1,2,3)
a = [1,2,3]
It's the same as in php ...
Regards, Stefan