Re: Reflection API
| From: | Andi Gutmans | Date: | Mon, 30 Jun 2003 18:48:16 +0000 |
| Subject: | Re: Reflection API | ||
| References: | 1 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-3053@lists.php.net to get a copy of this message | ||
At 11:44 AM 30/6/2003 -0400, George Schlossnagle wrote:
On Monday, June 30, 2003, at 11:35 AM, George Schlossnagle wrote:I still get the old .diff via the URL you posted. Can you please update it? Also, we should decide if we want to break the PHP function naming convention here. I assume most OO developers would prefer to write $obj->getName(), however, according to PHP standards it should be $obj->get_name(); In addition, as the engine is self-contained I think it would be better not to use PHP_ in the reflection API, i.e., instead of PHP_Function it would probably be nicer to use Reflection_Function or something similar. Let's finalize these issues and then personally I think we can go ahead and commit. AndiA look in sqlite answered my question - I should be using ZEND_NAMED_FE. Will update patch momentarily.Updated now.