Re: Reflection API
| From: | Andi Gutmans | Date: | Mon, 30 Jun 2003 19:10:05 +0000 |
| Subject: | Re: Reflection API | ||
| References: | 1 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-3058@lists.php.net to get a copy of this message | ||
At 02:01 PM 30/6/2003 -0400, George Schlossnagle wrote:
On Monday, June 30, 2003, at 02:48 PM, Andi Gutmans wrote:Yeah I know but they aren't updated with the ZE_FNAME() change you said you're doing :)At 11:44 AM 30/6/2003 -0400, George Schlossnagle wrote:The diff should be the same, since zend_reflection_api.[ch] aren't in cvs, they don't appear in the diff. They are there in their entirety as http://www.schlossnagle.org/~george/php/zend_reflection_api.c etc.On Monday, June 30, 2003, at 11:35 AM, George Schlossnagle wrote:I still get the old .diff via the URL you posted. Can you please update it?A look in sqlite answered my question - I should be using ZEND_NAMED_FE. Will update patch momentarily.Updated now.
I don't remember such an agreement but as I prefer the getName() syntax I won't argue :) If anyone disagrees, speak now or keep silent forever.Also, we should decide if we want to break the PHP function naming convention here. I assume most OO developers would prefer to write $obj->getName(), however, according to PHP standards it should be $obj->get_name();I was under the impression that there was tacit agreement that moving forward OO extensions would use PEAR standard naming, while procedural would use classic PHP style. That's the way Exception is.
Cool.In addition, as the engine is self-contained I think it would be better not to use PHP_ in the reflection API, i.e., instead of PHP_Function it would probably be nicer to use Reflection_Function or something similar.Okee dokee. Will be up by the time you get this mail.
:) AndiLet's finalize these issues and then personally I think we can go ahead and commit.Okee dokee.