Re: Patch for macros for tracking refcount and is_ref
| From: | David Wang | Date: | Tue, 11 Sep 2007 12:05:07 +0000 |
| Subject: | Re: Patch for macros for tracking refcount and is_ref | ||
| References: | 1 2 3 4 5 6 7 8 9 10 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-32244@lists.php.net to get a copy of this message | ||
> that's what worries me, I dont get why people wants to introduce yet
> another switch to disable to garbage collector ( that will lead to
> different/broken behaviuor) I think there is enough non-sense already
> with the unicode.semantics switch thingy.
This switch (currently) has nothing to do with the garbage collector.
If on, it prevents legacy code that do not use the refcount and is_ref
manipulation macros from compiling. That's all it does. In fact,
naming it ZEND_GC is misleading.
David