Re[2]: [PHP-DEV] array_has_more
| From: | Andi Gutmans | Date: | Fri, 04 Jul 2003 20:18:41 +0000 |
| Subject: | Re[2]: [PHP-DEV] array_has_more | ||
| References: | 1 2 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-3247@lists.php.net to get a copy of this message | ||
At 07:00 PM 4/7/2003 +0200, Marcus Börger wrote:
Hello Andi, damn, yeah, it was already to early in the morning when i sent the mail, i somehow didn't notice that i was trying to send a '.tx' file :-(What you are saying is that differentiating between a null value from next() and not having more elements is impossible without such a function? (I just want to be sure I understand what your motivation is). I don't really have a problem with array_has_more() the only problem is the name is not consistent with the other methods but on the other hand we don't allow new functions which don't follow the naming conventions. Catch-22? :) Andi
Friday, July 4, 2003, 11:55:01 AM, you wrote: AG> You forgot to attach the diff :) AG> Andi AG> At 03:56 AM 4/7/2003 +0200, Marcus Börger wrote:function isHello internals, during my todays work i was again reminded that still one arraylater onmissing namely array_has_more. This function will return true if there are more elements in an array and false if not. The real problem is that next() doesn't work with false. A diff against PHP 5 is attached. If noone objects i'll commit this-- Best regards,friday. Examle: <?php $ar = array(2,1,false,0); $i = 0; function show() { global $ar, $i; echo "loop: ";var_dump($i++); echo "curr: ";var_dump(current($ar)); echo "more: ";var_dump(array_has_more($ar)); echo "curr: ";var_dump(current($ar)); echo "next: ";var_dump(next($ar)); echo "\n"; } show(); show(); show(); show(); show(); show(); ?> -- Best regards,Marcus mailto:helly@php.net-- PHP Internals - PHP Runtime Development Mailing List To unsubscribe, visit: http://www.php.net/unsub.phpMarcus mailto:helly@php.net