Re[2]: [PHP-DEV] array_has_more

From: Date: Sat, 05 Jul 2003 04:34:26 +0000
Subject: Re[2]: [PHP-DEV] array_has_more
References: 1 2 3  Groups: php.internals 
Request: Send a blank email to internals+get-3253@lists.php.net to get a copy of this message
> What you are saying is that differentiating between a null value from > next() and not having more elements is impossible without such a function? > (I just want to be sure I understand what your motivation is). > I don't really have a problem with array_has_more() the only problem is the > name is not consistent with the other methods but on the other hand we > don't allow new functions which don't follow the naming conventions. > Catch-22? :) The key() can never become false which is why array_has_more is not needed. - Sascha

« previous php.internals (#3253) next »