Re: array_has_more

From: Date: Sat, 05 Jul 2003 18:40:15 +0000
Subject: Re: array_has_more
References: 1 2  Groups: php.internals 
Request: Send a blank email to internals+get-3268@lists.php.net to get a copy of this message
The problem isn't the ending. The problem is that according to our naming conventions it should be array_foobar() whereas the other array functions were invented before our conventions and are short names such as next(). Now on one hand we wouldn't want to pollute the PHP function space with new non-conforming function names but on the other hand it is really ugly to have a new function which looks completely different from the original ones... Andi At 01:25 PM 5/7/2003 -0400, Greg Beaver wrote:
Hi, How about array_has_next() to reference the php function? Greg Marcus BöRger wrote:
Anyway you said that you don't like the name really. Do you have a better name? If not i'll go with 'array_has_more'.


« previous php.internals (#3268) next »