alternative to the fopen() hack in autoloaders
| From: | Lukas Kahwe Smith | Date: | Tue, 10 Nov 2009 16:45:20 +0000 |
| Subject: | alternative to the fopen() hack in autoloaders | ||
| Groups: | php.internals | ||
| Request: | Send a blank email to internals+get-45992@lists.php.net to get a copy of this message | ||
Ahoi,
I have written an RFC for a more efficient solution to get rid of the common fopen() hack inside autoloaders:
if ($fp = @fopen($file, 'r', true)) {
fclose($fp);
include $file;
}
Here is the gist of the proposal:
In order to solve the above issues this RFC proposes the addition of a new construct/function for now called “autoload_include” for lack of a better name that largely behaves like the “include” does today with the following differences, that when the include failed because of a missing file no warning is raised and php null is returned.
Further details can be found on the wiki:
http://wiki.php.net/rfc/autoload_include
As stated in the RFC, I am not happy with the name "autoload_include". Suggestions welcome!
regards,
Lukas Kahwe Smith
mls@pooteeweet.org