Re: RFC: Making T_FUNCTION optional in method declarations
| From: | Ross Masters | Date: | Sat, 27 Nov 2010 18:35:40 +0000 |
| Subject: | Re: RFC: Making T_FUNCTION optional in method declarations | ||
| References: | 1 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-50635@lists.php.net to get a copy of this message | ||
+1, has crossed my mind before =)
"Johannes "Schlüter"" wrote in message news:1290879624.7033.826.camel@guybrush...
Hi,
every now and then while writing classes I forget to add the "function"
keyword between my visibility modifier and the method name in a class
declaration. I don't think it is required for readability and it is not
needed by the parser to prevent conflicts, I therefore propose the
following RFC incl. patch to allow writing
class Foo {
public bar() {
echo "Hello World";
}
}
Without T_FUNCTION token. In my opinion an access modifier /public,
private protected, static, final) should still be required for keeping
readability.
RFC: http://wiki.php.net/rfc/optional-t-function
Patch: http://schlueters.de/~johannes/php/zend_optional_t_function.diff
johannes