Re: Property Accessors v1.2

From: Date: Fri, 12 Oct 2012 08:22:24 +0000
Subject: Re: Property Accessors v1.2
References: 1  Groups: php.internals 
Request: Send a blank email to internals+get-63362@lists.php.net to get a copy of this message
Clint Priest wrote:
Alright, here is the updated RFC as per discussions for the last few days: https://wiki.php.net/rfc/propertygetsetsyntax-as-implemented If you could read it over, make sure I have all of your concerns correctly addressed and we can leave this open for the two week waiting period while I make the final code changes.
Now I remember why I did not like this wholesale ... There is no easy way to identify that $time->Hours = 12; is doing something other than a bog standard 'store 12 in $Hours' while a simple $time->Hours(12); immediately makes it obvious that there IS some processing involved. And period = $time->Hours(); flags that the result is calculated from some other value in the class. So IS this new layer of magic mirrors really necessary at all? Is it adding to the complexity at the expense of the inherent readability of the code later on? I suppose the argument is that 'people expect it' but that is only because they are not yet used to the better way of working that IS PHP ... just because some people expect cryptic code should that be any reason to weigh PHP down further with it? -- Lester Caine - G8HFL ----------------------------- Contact - http://lsces.co.uk/wiki/?page=contact L.S.Caine Electronic Services - http://lsces.co.uk EnquirySolve - http://enquirysolve.com/ Model Engineers Digital Workshop - http://medw.co.uk Rainbow Digital Media - http://rainbowdigitalmedia.co.uk

« previous php.internals (#63362) next »