Re: [RFC] Skipping parameters take 2

From: Date: Mon, 02 Sep 2013 07:41:13 +0000
Subject: Re: [RFC] Skipping parameters take 2
References: 1 2  Groups: php.internals 
Request: Send a blank email to internals+get-68829@lists.php.net to get a copy of this message
Hi! > I am not sure whether this is a little overhead. > > but if we do want this. to be honest, I even prefer leave it empty to > "default". > > like create_query("delete=0", "name", , , true); That's how it was initially, and I was convinced default is better. So I don't think I'm going back to empty. default indeed seems to be more readable (try to visually distinguish between ,,,, and ,,,, - if you have a lot of code, it won't be that easy). It is more verbose, but PHP never attempted to be "save the bytes" language. -- Stanislav Malyshev, Software Architect SugarCRM: http://www.sugarcrm.com/ (408)454-6900 ext. 227

« previous php.internals (#68829) next »